通达信指标公式买卖一根线主图指标源码

     股票     发布时间:2019-08-16 18:16
原文标题:通达信指标公式买卖一根线主图指标源码

通达信买卖一根线主图指标源码:

VAR4:=((HHV(HIGH,9) - CLOSE)/(HHV(HIGH,9) - LLV(LOW,9)))*(100) - 70;

VAR5:=((CLOSE - LLV(LOW,60))/(HHV(HIGH,60) - LLV(LOW,60)))*(100);

VAR7:=SMA(((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100),3,1);

VAR8:=LLV(LOW,34);

VARC:=EMA(((((2)*(CLOSE) + HIGH + LOW)/(4) - VAR8)/(HHV(HIGH,34) - VAR8))*(100),8);

VARD:=EMA(VARC,5);

VARE:=((HHV(HIGH,9) - CLOSE)/(HHV(HIGH,9) - LLV(LOW,9)))*(100) - 70;

VAR11:=SMA(((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100),3,1);

VAR12:=SMA(VAR11,3,1) + 100;

VAR13:=VAR12 - SMA(VARE,9,1) + 100;

VAR14:=ZIG(3,13);

建仓:=IF((VARC > 17) AND (VARC < 59) AND (VARC - VARD >= 0),10,(-10));

猎豹:=IF((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),10,45);

丰收:=IF((VARC > 70) AND (VARC - VARD >= 0),77,82);

牛:=IF((VAR13 > 100),VAR13 - 100,0);

顶:=IF((REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),95,55);

风:=IF((VARC - VARD > 0),VARC,VARD);

STICKLINE((REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),CLOSE,OPEN,5,0),Color66FF00;

STICKLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),CLOSE,OPEN,5,0),coloryellow;

DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1))AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick5,Color070084;

DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1))AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick4,Color0000A3;

DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1))AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick3,Color0000B7;

DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1))AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick2,Color0000CD;

DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1))AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick1,Color077BF3;

STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),ColorFF5B00;

STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,4.5,0),ColorFF6C00;

STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,4,0),ColorFF7B00;

STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),ColorFF9C00;

STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2,0),ColorFFBE00;

STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1,0),ColorFFCC00;

STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,0.5,0),ColorCCCCCC;

STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),Color070084;

STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4.5,0),Color0000A3;

STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),Color0000B7;

STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3.5,0),Color0000CD;

STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),Color0000E9;

STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),Color0754E9;

STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),Color076EF3;

STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,0.5,0),Color077BF3;

STICKLINE((CLOSE > OPEN),OPEN,LOW,0.5,0),Color0726CA;

STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0.5,0),Color0726CA;

STICKLINE((OPEN > CLOSE),CLOSE,LOW,0.5,0),ColorDE9100;

STICKLINE((OPEN > CLOSE),OPEN,HIGH,0.5,0),ColorDE9100;

买:DRAWTEXT((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.05),'买'),colorred;

卖:DRAWTEXT((REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.03),'卖'),Color66FF00;

STICKLINE((REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),CLOSE,OPEN,5,0),Color66FF00;

STICKLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),CLOSE,OPEN,5,0),coloryellow;


标签: 指标 公式 源码